Preliminary Performance Improvement Results

"
PsOfOs wrote:
I'm still waiting for my quantum processor,hope it gets released soon.
Should see some improvement on minimum fps i think.
I mean reading about 3k $ and above rigs having trouble with this game?
Well done Chris.
Can you move to PoE 2 on a new engine any time soon?
Could even be cheaper than trying to sort this mess you have there for 4 years now.


I have a Core i7-920 from 2009 and a GTX 680 from 2012. So a 7 year old rig with 4 year old upgrades. Original system was probable $2k-something, but now worth may be around $600 or less. Good performance in PoE both before and after changes, enough to max settings except shadows while playing @ 2560x1600 and still be way over 60FPS a majority of the time. Therefore your argument is invalid.
▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
▒▒▒▒░░░░░ cipher_nemo ░░░░░▒▒▒▒ │ Waggro Level: ♠○○○○ │ 1244
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀
Last edited by cipher_nemo on Aug 4, 2016, 4:27:12 PM
"
Baron01 wrote:
Something is fishy with the test/beta version of performance improvements.

I did some testing with and without multi-threading support and I observed the following:
- performance in town, Act 4, was worse when multi-threading (MT) support was on, the game was very choppy immediately after loading into town, noticeably more than when MT was off.
- I got higher top-end FPS with MT ON
- I got much bigger drops/fluctuation of FPS with MT ON (my FPS was between 49 and 63 most of the time when MT was off, my FPS could shoot up to 111 but also drop down to 20 with MT ON)
- my FPS was very jumpy with MT ON, almost never forming a flat line, always up and down

My computer has:
i7-4790k
16GB RAM
GTX 970
SSD


Would you mind running the game in Windowed mode with MT on and having CPUID ( AKA CPU-z ) running to see if the fluctuations correlate to the frequency of the processor, or changes in the COUP multiplier?
I'm wondering if the unlcoked multiplier or turbo boost may be causing some instability with the results.

Also, the 4790K is also known to be targeted at overclockers. Is your machine running at stock, or is it overclocked?

Maybe post the results in the tech support forum...
"I would have listened... I would have understood!" - Scion

Have you removed Asus ROG/GameFirst yet?
Just get rid of the fuckin ground effects. It's not like anyone LIKES them or thinks it adds anything to the game.

Either rebuild the game engine to not be engineered poorly, quit adding shit on top or start cutting things out.
"
CorranHorn wrote:
Just get rid of the f***in ground effects. It's not like anyone LIKES them or thinks it adds anything to the game.


I wouldn't say "get rid of" them, but an option to toggle certain categories of effects on and off would be nice. They're nice eye candy for new players, but those of us who've played for some time aren't really that interested in seeing them all the time.

"
CorranHorn wrote:
Either rebuild the game engine to not be engineered poorly, quit adding shit on top or start cutting things out.


How do you know it's "engineered poorly"? So far PoE runs fairly smooth compared to a lot of other indie titles out there. Sure, it could be better, but they don't need to create a whole new engine or switch to some popular, pre-built engine.

You want to turn off effects, but I'd rather see GGG give us an option to disable groups of effects.

▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
▒▒▒▒░░░░░ cipher_nemo ░░░░░▒▒▒▒ │ Waggro Level: ♠○○○○ │ 1244
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀
Crashed 5-7 times today. Nice performance improvement.
I just wanted to say that i am not even using the new option but i am constantly crashing since this new thing was implicated..."poe stopped working" i am even sending error reports every time it happens but still...and even this latest "hotfix" patch did not change anything for me, still crashing without even trying this new feature :(
I just wanted to say that i am not even using the new option but i am constantly crashing since this new thing was implicated..."poe stopped working" i am even sending error reports every time it happens but still...and even this latest "hotfix" patch did not change anything for me, still crashing without even trying this new feature :(
I just wanted to say that i am not even using the new option but i am constantly crashing since this new thing was implicated..."poe stopped working" i am even sending error reports every time it happens but still...and even this latest "hotfix" patch did not change anything for me, still crashing without even trying this new feature :(
lookin good
Game is crashed more than ever, with and without the beta command on.

Report Forum Post

Report Account:

Report Type

Additional Info