[3.12] LIGHTNING ARROW/BARRAGE Deadeye Build / Zap your way forward! UBER ELDER DONE!

"

it's a nice build, but need some investment and love. Once you get everything it's pretty damn fun and fast. Doing it as a first build can be slow though, bow builds in general are considered a "zoom zoom" builds and are mostly geared for speedfarming of low content very fast, like endless Burial Chambers.
This build can do all major content, i've build it to be good for everything, like i always do.


First of all thanks a lot for the fast reply :). I think I'll give it a try even if it takes me a while to get it rolling.
Hey,will you going to update it to 3.12? Or we can still use this?
"
UnExpiration wrote:
Hey,will you going to update it to 3.12? Or we can still use this?

nothing to update for now
https://www.twitch.tv/angry_roleplayer
All builds: http://www.angryroleplayer.com/path-of-exile-builds/
https://www.pathofexile.com/forum/view-thread/2143469
What do you think about using Lightning Penetration Support gem on skills? can it stack with Shroud of The Lightless?
"
UnExpiration wrote:
What do you think about using Lightning Penetration Support gem on skills? can it stack with Shroud of The Lightless?

No it can't
https://www.twitch.tv/angry_roleplayer
All builds: http://www.angryroleplayer.com/path-of-exile-builds/
https://www.pathofexile.com/forum/view-thread/2143469
Hello, friend. Build looks good, but I just couldn't open the pob. I get an error message about unknown passive tree version. I already tried updating, but apparently I already have the last version of the program, 1.4.170. Am I doing something wrong? Thanks in advance for any help. =)

P. D.: I also tried to import the pob on your tecto slam jugg guide and it happened the same. I've been able to import other pobs and also import my own character from my account.
Last edited by Cejon Raul on Sep 25, 2020, 11:51:06 PM
"
Cejon Raul wrote:
Hello, friend. Build looks good, but I just couldn't open the pob. I get an error message about unknown passive tree version. I already tried updating, but apparently I already have the last version of the program, 1.4.170. Am I doing something wrong? Thanks in advance for any help. =)

P. D.: I also tried to import the pob on your tecto slam jugg guide and it happened the same. I've been able to import other pobs and also import my own character from my account.

You need pob fork
https://www.twitch.tv/angry_roleplayer
All builds: http://www.angryroleplayer.com/path-of-exile-builds/
https://www.pathofexile.com/forum/view-thread/2143469
"
"
Cejon Raul wrote:
Hello, friend. Build looks good, but I just couldn't open the pob. I get an error message about unknown passive tree version. I already tried updating, but apparently I already have the last version of the program, 1.4.170. Am I doing something wrong? Thanks in advance for any help. =)

P. D.: I also tried to import the pob on your tecto slam jugg guide and it happened the same. I've been able to import other pobs and also import my own character from my account.

You need pob fork

Got it and made it work. Tyvm, sir.
Can this be played as raider too?
"
Vanevoly wrote:
Can this be played as raider too?

Can be done, but will be much less quality of life
https://www.twitch.tv/angry_roleplayer
All builds: http://www.angryroleplayer.com/path-of-exile-builds/
https://www.pathofexile.com/forum/view-thread/2143469

Report Forum Post

Report Account:

Report Type

Additional Info