The new graphical Bloom effect is BLECH even on low

Yes, we need an option to turn it off completely.
No soapy water all over my monitor, please
Beware of the man who works hard to learn something, learns it, and finds himself no wiser than before. He is full of murderous resentment of people who are ignorant without having come by their ignorance the hard way.
As someone who suffers from simulation sickness, being able to adjust visual settings greatly improves my ability to play for any amount of time. Bloom is often one of the worst offenders (second only to motion blur), so I second the ability to remove it from the game.
I would turn it off if I could. Pls let me GGG.
It's [Removed by Support]. Everything looks like a christmas tree now, really painful to look at.
Please, bring back the option to turn it off.
Last edited by Natasha_GGG on Jun 19, 2020, 9:19:34 PM
What is this 2005? Bloom is such a cheap fake looking effect.
+1 Please allow us to disable it completely.
I always deactivate motion blur and bloom effects in FPS. GGG please add an option to deactivate bloom, It's causing fps drops.
Zewks wrote:
Ive always hated bloom in games. It makes my eyes strain to look at the screen. Plus, I just dont think the added glowy hazy blurry effect around lights is visually good. It covers up the nice crisp detailed graphics that I spent so much money on my pc and monitor to see.

First thing I noticed when I entered the game this season was this new effect. I was happy to see a video option to set it to "low" rather than "default". Even on low, however, its still just too much for my eyes to look at without giving me eye strain (which ultimately leads to headaches).

Please please please give us another option to disable it completely.


I loaded in to the game with Vulkan, walked down to the Town Portal and the issue with bloom was immediately obvious. Everything is drowned out by it. The issue is lessened but not eliminated when Bloom is set to the reduced option.

Bloom is supposed to compliment the appearance of things, not be a dominant effect. I feel like that VGCats comic on bloom needs referencing... so here it is:
Computer specifications:
Windows 10 Pro x64 v2004 | AMD Ryzen 3700X | ASUS Crosshair VIII Hero (WiFi) Motherboard | 16GB 3600MHz RAM | MSI Geforce 1070Ti Gamer | Corsair AX 760watt PSU | Samsung 860 Pro 512GB SSD/WD Black FZEX HDD
Bloom is blooming awful.
𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣𓆣 SCARABS!
ERRR THeres an option in graphic settings, Bloom Normal(Default), u can set it to Bloom(Slight) and the fog will gone back to previous looks.
Last edited by imcominghehee on Jun 20, 2020, 9:20:36 AM

Report Forum Post

Report Account:

Report Type

Additional Info